Egret社区
1银子
本帖最后由 hzj730 于 2018-10-12 20:21 编辑

加载到99%报错,到底global在该平台可用吗??

Execute JS Error![Error: polyfill failed because global object is unavailable in this environment]

已解决,我用的5.2.10的引擎版本,promise不对,需要用文档中提到的github上的那个老的稳定版本才行。地址:https://github.com/egret-labs/eg ... ckEngineGame/Res/js

最佳答案

查看完整内容

这个是你项目构建的版本太低了,要在5.2.4以上版本,你可以重新建立项目,重新发布就好了(本质上promise的版本问题)
分享到 :
0 人收藏

2 个回复

倒序浏览
liyi20080  登堂入室 | 2018-10-11 20:40:56
这个是你项目构建的版本太低了,要在5.2.4以上版本,你可以重新建立项目,重新发布就好了(本质上promise的版本问题)
hzj730  登堂入室 | 2018-10-12 20:20:30
liyi20080 发表于 2018-10-12 16:17
这个是你项目构建的版本太低了,要在5.2.4以上版本,你可以重新建立项目,重新发布就好了(本质上promise的 ...

是的,已解决,我用的5.2.10的引擎版本,promise不对,需要用文档中提到的github上的那个老的稳定版本才行。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|京网文[2014]0791-191号|京ICP证150115号|Egret社区 ( 京ICP备14025619号

Powered by Discuz! X3.2 © 2001-2019 Comsenz Inc.

返回顶部