Egret社区

[EgretEngine] 4.0的性能比旧版本差吗

2017-3-28 13:30
345210
本帖最后由 airy 于 2017-3-28 15:46 编辑

想在地图上面显示网格,就在循环里面创建Shape画直线,
如果循创建的shape超过100,直接浏览器都崩了,
项目使用的engine改成3.0.3, 3.0.2, 3.0.1, 2.5.6都没有问题可以正常创建出网格,如果换到4.0+以上的版本chrome就崩了。。。代码如下:
默认循环100次,4.0+会崩掉,如果低版本,几百次都不会挂,都是瞬间打开没有问题
环境:
系统 osx 10.1  4核16G
chrome 版本 56.0.2924.87 (64-bit)
aaaa.png
分享到 :
0 人收藏

10 个回复

倒序浏览
yjtx  官方团队 | 2017-3-28 13:52:29
麻烦把demo提供下,顺便说下具体测试的机型、系统版本、浏览器版本
xucore  登堂入室 | 2017-3-28 14:41:15
可以检查一下是不是写了4.0不兼容的代码,或者是查看文档看看这部分代码在4.0中运行机制不一样。我原本的游戏项目在3.2.6中开发,后来升级为4.0.0、4.0.3都未发生问题,效率也没有降低
airy  登堂入室 | 2017-3-28 15:13:39
yjtx 发表于 2017-3-28 13:52
麻烦把demo提供下,顺便说下具体测试的机型、系统版本、浏览器版本

这论坛实在体验太差了,就几行代码我想在这里贴一下都不可以
airy  登堂入室 | 2017-3-28 15:34:39
yjtx 发表于 2017-3-28 13:52
麻烦把demo提供下,顺便说下具体测试的机型、系统版本、浏览器版本

上传到附件了
airy  登堂入室 | 2017-3-28 15:35:42
xucore 发表于 2017-3-28 14:41
可以检查一下是不是写了4.0不兼容的代码,或者是查看文档看看这部分代码在4.0中运行机制不一样。我原本的游 ...

我直接用4.0.3创建的,就只写了for循环
yjtx  官方团队 | 2017-3-28 17:36:54

~ 没有上传上,麻烦重新上传下,还有麻烦提供下手机型号、系统版本、浏览器版本
airy  登堂入室 | 2017-3-28 18:37:28
yjtx 发表于 2017-3-28 17:36
~ 没有上传上,麻烦重新上传下,还有麻烦提供下手机型号、系统版本、浏览器版本 ...

你们论坛上传不了zip包,我贴了图片,你直接看贴子内容
yjtx  官方团队 | 2017-3-29 09:40:18
airy 发表于 2017-3-28 18:37
你们论坛上传不了zip包,我贴了图片,你直接看贴子内容

不会的呀,zip包不要超过 5M,通过附件上传
airy  登堂入室 | 2017-3-29 11:11:54
yjtx 发表于 2017-3-29 09:40
不会的呀,zip包不要超过 5M,通过附件上传

你看帖子内容有代码,总共就几行,你看看会崩溃不
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|京网文[2014]0791-191号|京ICP证150115号|Egret社区 ( 京ICP备14025619号 )

Powered by Discuz! X3.4 © 2001-2019 Comsenz Inc.

返回顶部