Egret社区
运行报,Nonsupport data version.,
引擎版本5.0.13,以及5.0.14都不支持
是版本问题吗,还是其他的
分享到 :
0 人收藏

6 个回复

倒序浏览
duanchunlei  官方团队 | 2018-2-9 09:39:44
是你的数据加载出错了,看看你加载的是什么数据,如果不理解,可以看龙骨 github 官网的 js 的 egret 例子,龙骨启动 log 每次都打印这个网址,就是担心开发者不去看官网的例子。
flep  社区管理员 | 2018-2-9 09:55:38
导出的二进制文件包括 xxx_ske.dbbin , xxx_tex.json ,  xxx_tex.png   其中动画文件是xxx_ske.dbbin .  xxx_tex.json 是纹理集配置文件。
哈尔的移动城堡  登堂入室 | 2018-2-9 16:08:55
duanchunlei 发表于 2018-2-9 09:39
是你的数据加载出错了,看看你加载的是什么数据,如果不理解,可以看龙骨 github 官网的 js 的 egret 例子 ...

关键是官网的下载龙骨动画播放成功了
QQ图片20180209160602.png
哈尔的移动城堡  登堂入室 | 2018-2-9 16:11:29
flep 发表于 2018-2-9 09:55
导出的二进制文件包括 xxx_ske.dbbin , xxx_tex.json ,  xxx_tex.png   其中动画文件是xxx_ske.dbbin .  xx ...

包括了,知道就这三个,本来打算极速格式的,但是龙骨5.6版本提示可能包含网格或者碰撞不能导出极速格式,才选择二进制格式导出
哈尔的移动城堡  登堂入室 | 2018-2-9 16:37:45
duanchunlei 发表于 2018-2-9 09:39
是你的数据加载出错了,看看你加载的是什么数据,如果不理解,可以看龙骨 github 官网的 js 的 egret 例子 ...

单单新建5.1.3播放成功,但是低版本升级上来5.1.3的不可用,会报上诉错误
哈尔的移动城堡  登堂入室 | 2018-2-9 16:50:01
duanchunlei 发表于 2018-2-9 09:39
是你的数据加载出错了,看看你加载的是什么数据,如果不理解,可以看龙骨 github 官网的 js 的 egret 例子 ...

目前简单解决了,原因是从低版本升上来的白鹭项目egret.min.js里有个版本号依然不是最新的版本,需要手动修改至当前版本(如4.0.3到5.0.13)
QQ图片20180209164613.png
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|京网文[2014]0791-191号|京ICP证150115号|Egret社区 ( 京ICP备14025619号 )

Powered by Discuz! X3.4 © 2001-2019 Comsenz Inc.

返回顶部