Egret社区
10银子
请教一个问题, 白鹭官方的greensock可以用, 但是版本太旧了, 最新版本都2.02了, 官方一直是1.13, 官方也一直不更新的 . 所以我想用最新greensock, 想把最新版本的导入白鹭, 但是看了官方第三方教程, 一直没成功, 想请教一下!greenscok下载后, 所有文件是分散的! 如何把他们合并一个JS呢? 有什么工具吗?

分享到 :
0 人收藏

3 个回复

倒序浏览
山猫  初窥堂奥 | 2019-3-5 15:41:00
你下载下,把里面的库换成新的试一试egret-game-library/greensock/libsrc/bin/greensock/
幻白一驹  圆转纯熟 | 2019-3-5 18:17:19
山猫 发表于 2019-3-5 15:41
你下载下,把里面的库换成新的试一试egret-game-library/greensock/libsrc/bin/greensock/ ...

兄弟, 我不会弄才问你哒, 带我向官方说一下, 快把这个更新一下吧, 没有greensock无动画, 我把下载地址给你, https://www.tweenmax.com.cn/source/  然后让官方替换一下吧
youwh  登堂入室 | 2019-3-6 10:33:59
上git找 greensock 的 typedefinition 文件 (greensock.d.ts) ,放入跟src(保留minified就可以了)同样的文件夹(greensock),然后在egretproperties.json 加入
  {
      "name": "greensock",
      "path": "../libs/greensock" (里面有src跟greensock.d.ts)
    }
应该就可以了(不是很确定怎么弄了)
发布的时候会有个 greensock.min.js
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|京网文[2014]0791-191号|京ICP证150115号|Egret社区 ( 京ICP备14025619号 )

Powered by Discuz! X3.4 © 2001-2019 Comsenz Inc.

返回顶部