Egret社区
10银子
1.创建oppo工程 报错提示缺失config.oppogame.ts
2.创建oppo工程 会报错 FATAL ERROR: CALL_AND_RETRY_LAST Allocation failed - JavaScript heap out of memory




请问下是什么姿势不对么  还是config.oppogame.ts 本身就需要自己创建 还有oppo发布 提示的内存报错 要怎么办




最佳答案

查看完整内容

我打开了我5.2.21版本引擎的一个项目,里面是有config.oppogame.ts,说明要码你引擎版本太低,要马你升级引擎时是直接改的egretProperties.json的版本号,你可以新建一个有这个文件的空项目,复制到你的项目,或者把egretProperties.json的版本号改到之前的,然后用命令行升级引擎版本到有config.oppogame的版本。如果是其他的情况在下也不知道是为啥 ...
分享到 :
0 人收藏

9 个回复

倒序浏览
a18050123231  圆转纯熟 | 2019-7-23 16:15:41
我打开了我5.2.21版本引擎的一个项目,里面是有config.oppogame.ts,说明要码你引擎版本太低,要马你升级引擎时是直接改的egretProperties.json的版本号,你可以新建一个有这个文件的空项目,复制到你的项目,或者把egretProperties.json的版本号改到之前的,然后用命令行升级引擎版本到有config.oppogame的版本。如果是其他的情况在下也不知道是为啥
M5644  登堂入室 | 2019-7-23 17:33:48
求助各位大神
常歌行  圆转纯熟 | 2019-7-23 17:42:27
M5644  登堂入室 | 2019-7-23 17:43:22
常歌行 发表于 2019-7-23 17:42
是按照官方文档操作的吗http://developer.egret.com/cn/github/egret-docs/Engine2D/minigameoppo/getStart ...

对的  安装完 直接点击的确定
M5644  登堂入室 | 2019-7-23 17:44:35
a18050123231 发表于 2019-7-23 17:43
我打开了我5.2.21版本引擎的一个项目,里面是有config.oppogame.ts,说明要码你引擎版本太低,要马你升级引 ...

好的 大神 我试试
M5644  登堂入室 | 2019-7-23 17:49:08
a18050123231 发表于 2019-7-23 17:43
我打开了我5.2.21版本引擎的一个项目,里面是有config.oppogame.ts,说明要码你引擎版本太低,要马你升级引 ...

嗯嗯 之前用的是 5.2.22  改回用了5.2.21  update一下就好了!!
M5644  登堂入室 | 2019-7-23 17:50:43
常歌行 发表于 2019-7-23 17:42
是按照官方文档操作的吗http://developer.egret.com/cn/github/egret-docs/Engine2D/minigameoppo/getStart ...

现在可以了~
a18050123231  圆转纯熟 | 2019-7-23 17:52:14

我发现官方的老哥回答问题经常问牛打码耶
M5644  登堂入室 | 2019-7-23 17:53:22
a18050123231 发表于 2019-7-23 17:52
我发现官方的老哥回答问题经常问牛打码耶

重启 不行 重装
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|京网文[2014]0791-191号|京ICP证150115号|Egret社区 ( 京ICP备14025619号 )

Powered by Discuz! X3.4 © 2001-2019 Comsenz Inc.

返回顶部