Egret社区

请问egret native支持es6吗?

2020-10-14 11:47
1846
请问egret native支持es6吗?
分享到 :
0 人收藏

6 个回复

倒序浏览
app小王子  社区管理员 | 2020-10-14 12:57:30
ios 8-9 的 js执行引擎 不支持 es6 所以 无法支持
除非选择 不支持这些ios 系统
lin3348  初学乍练 | 2020-10-14 14:08:51
app小王子 发表于 2020-10-14 12:57
ios 8-9 的 js执行引擎 不支持 es6 所以 无法支持
除非选择 不支持这些ios 系统
...

请问安卓的是否支持?安卓native用的是webview内核是哪个?
lin3348  初学乍练 | 2020-10-14 14:10:11
app小王子 发表于 2020-10-14 12:57
ios 8-9 的 js执行引擎 不支持 es6 所以 无法支持
除非选择 不支持这些ios 系统
...

请问安卓的是否支持,安卓native用的webview内核是哪个?javascript引擎内核是否也支持到es6
lin3348  初学乍练 | 2020-10-14 14:13:24
请问安卓的是否支持,安卓native用的webview内核是哪个?javascript引擎内核是否也支持到es6
lin3348  初学乍练 | 2020-10-14 14:18:19
app小王子 发表于 2020-10-14 12:57
ios 8-9 的 js执行引擎 不支持 es6 所以 无法支持
除非选择 不支持这些ios 系统
...

请问安卓的是否支持,安卓native用的webview内核是哪个?javascript引擎内核是否也支持到es6?按照回复来说,只要不关注ios8-9,就可以使用es6?虽然es6的语法可以使用babel,但是polyfill不想带上,毕竟比较大,例如Map,Set之类的内建类型,不知道安卓的支持情况.
app小王子  社区管理员 | 2020-10-14 15:46:16
lin3348 发表于 2020-10-14 14:18
请问安卓的是否支持,安卓native用的webview内核是哪个?javascript引擎内核是否也支持到es6?按照回复来 ...

意思是native不支持es6. 如果你需要支持的包的话 欢迎添加我的微信egretengine.我们可以给你提供定制包。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|京网文[2014]0791-191号|京ICP证150115号|Egret社区 ( 京ICP备14025619号 )

Powered by Discuz! X3.4 © 2001-2019 Comsenz Inc.

返回顶部