Egret社区
1、用Egret Launcher新建项目,vscode自动打开,但打开的并不是项目目录。2、按F5调试根本跑不起来,浏览器里只有下面内容
无法访问此网站
localhost 拒绝了我们的连接请求。



3、编译速度比5.3.X慢多了,就一个新建项目就要5秒



请问上面问题这样解决?
到底5.4.0是不是稳定版?搞了一个多小时,说明文档也没有,网上完全没人讨论5.4.0,连这个社区也几乎没人讨论5.4.0我都快奔溃了!
分享到 :
0 人收藏

3 个回复

倒序浏览
app小王子  社区管理员 | 2021-2-20 17:51:11
5.4.0 是我们的年前刚发的稳定版本。
您说的第一个问题我这边没有出现这种情况;
第二个问题,你修改一下修改下scripts/config.ts文件中 command == 'build' 选项中的编译器试试呢?
                   // new WebpackBundlePlugin({ //新的 Webpack 编译器
                    //     libraryType: "debug",
                    //     defines: { DEBUG: true, RELEASE: false },
                    //     typescript: { mode: 'legacy' },
                    //     html: {
                    //         templateFilePath: "template/web/index.html"
                    //     }
                    // }),
                    new WebpackDevServerPlugin({ //新的 Webpack 编译器
                        libraryType: "debug",
                        defines: { DEBUG: true, RELEASE: false },
                        typescript: { mode: 'legacy' },
                        html: {
                            templateFilePath: "template/web/index.html"
                        },
                        open: false
                    }),
第三个问题,我这边也没有遇到过。
更多内容,您可以添加我的微信 egretengine  沟通一下哦

japper  登堂入室 | 2021-2-22 14:33:09
app小王子 发表于 2021-2-20 17:51
5.4.0 是我们的年前刚发的稳定版本。
您说的第一个问题我这边没有出现这种情况;
第二个问题,你修改一下修 ...

能看看你们的
.vscode/launch.json
这个文件里面是啥样的吗~
我现在每次重启vscode,都要重新覆盖端口号
japper  登堂入室 | 2021-2-23 09:36:23
app小王子 发表于 2021-2-20 17:51
5.4.0 是我们的年前刚发的稳定版本。
您说的第一个问题我这边没有出现这种情况;
第二个问题,你修改一下修 ...

我新建一个5.4.0项目,创建了一个自定义的skin
但是没有自动生成 libs/exml.e.d.ts这个文件
是被移除了吗?
以前指定皮肤就是this.skinName = skins.XXXX
现在没有这个exml.e.d.ts,就只能手敲字符串了
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|京网文[2014]0791-191号|京ICP证150115号|Egret社区 ( 京ICP备14025619号 )

Powered by Discuz! X3.4 © 2001-2019 Comsenz Inc.

返回顶部