Egret社区
发现更新到新版本后多了个egret_require.js,native_loader.js,egret_loader.js。而且其他目录结构也发生了些变化,先不管这些。但是native_loader.js跟egret_loader.js能解释根本什么时候会有用么?因为发布后的文件夹里是没有native_loader.js。
看里面的代码
   egret_native.EGTView.setDesignSize(480, 800);
    context.stage = new egret.Stage(480, 800);
    egret.RendererContext.CONTENT_SCALE_FACTOR = 1;

    context.run();

    var document_class = "GameApp";
    var rootClass;
    if(document_class){。。。

也有布局尺寸,还有什么文档类文档类的类名,这些编译也没有自动生成,应该是要手动改的,那这样更改布局更改文档类名称是不是还需要同时改这个文件?布局更改已经涉及到egret_loader.js,index.html,release.html,egretProperties.json(改文档类名称,模块等),还要再加这个文件?

是不是egret编译部分的信息配置能统一到一个配置文件中让开发者去改?否则是不是很杂?





分享到 :
0 人收藏

2 个回复

倒序浏览
生活在别处  初学乍练 | 2014-8-26 11:57:26
:
A闪  社区管理员 | 2014-8-26 12:04:24
native_loader.js是用来打包iOS和Android版本用的,H5中用不到native_loader.js
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|京网文[2014]0791-191号|京ICP证150115号|Egret社区 ( 京ICP备14025619号 )

Powered by Discuz! X3.4 © 2001-2019 Comsenz Inc.

返回顶部